Erro na atualização do sistema

Victor
Mensagens: 181
Registrado em: 06 Mai 2011, 12:51

Erro na atualização do sistema

Mensagem por Victor » 15 Fev 2012, 14:08

Boa Tarde,

Uma colega cometeu um engano ao tentar atualizar o biblivre.

Ela desistalou o biblivre sem efetuar o backup.

Ao tentar intalar a nova versão a máquina dela apresenta a mensagem que necessário instalar o postgres.

Como ela pode instalar novamente o programa sem perder os registos já catalogados?

Victor

wlucas
Administrador
Mensagens: 1971
Registrado em: 30 Abr 2011, 10:38

Re: Erro na atualização do sistema

Mensagem por wlucas » 16 Fev 2012, 08:38

Boa tarde Victor.

Na pasta Arquivos de Programas -> PostgreSQL, terá dentro a pasta da versão: 8.1, 8.3, 8.4 ou 9.1

Dependendo da versão, terá que instalar o Postgresql referente, para depois disso fazer o backup.

http://www.enterprisedb.com/products-se ... ad#windows

Se for pedido senha: abracadabra e a porta é a 5432.

Use o BackupRestore anexo para fazer o backup, executando pelo BackupRestore.jar

Se der algum erro, poderá ser usado via linha de comando.

No Prompt de commando modifique este exemplo dependendo da versão:

"C:\Arquivos de programas\PostgreSQL\8.1\bin\pg_dump" -U postgres biblivre3 -f "C:\Backup_Biblivre\biblivre_3.sql


Se conseguir fazer a cópia de segurança (backup), instale o Biblivre3 que será aproveitado o banco.

Atenciosamente. :ugeek:
Anexos
BackupRestore.rar
(476.58 KiB) Baixado 385 vezes

Responder

Voltar para “Mensagens de erros mais frequentes”