Instalar com versões mais novas do postgres, tomcat e apache

davilv
Mensagens: 9
Registrado em: 17 Ago 2011, 16:06

Re: Instalar com versões mais novas do postgres, tomcat e ap

Mensagem por davilv » 05 Out 2011, 09:45

Lucas, realmente deve está faltando algo no meu procedimento. Vou citar os passos que estou seguindo e por favor, me indique onde posso estar errando.
Faço a instalação na seguinte ordem:
java jre6u27;
apache (o mesmo do instalador)
tomcat 6.0.33 (e coloco o postgresql-9.0-802.jdbc3.jar na pasta lib)
Instalo o postgres, coloco a senha do super user como "abracadabra", carrego a base vazia que vc indicou, e depois crio o usuário biblivre (seguindo o que vc falou) e o coloco como owner do banco biblivre3.

Então tento instalar o biblivre, mas aí ele não encontra o postgres.

Com esses passos, dá pra saber o que está faltando?

wlucas
Administrador
Mensagens: 1975
Registrado em: 30 Abr 2011, 10:38

Re: Instalar com versões mais novas do postgres, tomcat e ap

Mensagem por wlucas » 06 Out 2011, 08:56

Bom dia Davilv.

O instalador do Biblivre 3 , não esta configurado para os programas novos, especialmente, Postgresql 9, portanto ele nunca vai achar.
Como eu te disse antes, vc tem que fazer tudo manualmente, ou seja, para o seu caso, não use o instalador.

Vc deve baixar e salvar o biblivre3.war na pasta : C:\Program Files\Apache Software Foundation\Tomcat 6.0\webapps
e reiniciar o Tomcat.

http://www.megaupload.com/?d=W1QDEVZS

Vc deve criar a pasta Biblivre 3 em Program Files e descompactar dentro o arquivo abaixo.

Obs.: Em Biblivre 3, existe um espaço entre o nome e o 3, digo isso para futuras instalações ou atualizações que irão salvar dados nessa pasta, portanto se for criado como Biblivre3, poderá causar incovenientes.

http://www.megaupload.com/?d=L337BX8H

Crie os atalhos
Target: "C:\Program Files\Biblivre 3\Biblivre 3.url"
Start in: "C:\Program Files\Biblivre 3"

Target: C:\Windows\system32\java.exe -jar "C:\Program Files\Biblivre 3\BackupRestore.jar"
Start in: "C:\Program Files\Biblivre 3"

Imagem


Atenciosamente. :ugeek:

davilv
Mensagens: 9
Registrado em: 17 Ago 2011, 16:06

Re: Instalar com versões mais novas do postgres, tomcat e ap

Mensagem por davilv » 06 Out 2011, 17:51

Lucas, consegui. Valeu cara, obrigado mesmo pela forçona que vc me deu.

Obrigado.

wlucas
Administrador
Mensagens: 1975
Registrado em: 30 Abr 2011, 10:38

Re: Instalar com versões mais novas do postgres, tomcat e ap

Mensagem por wlucas » 06 Out 2011, 19:56

Foi um prazer ajudá-lo :lol:

Atenciosamente. :mrgreen:

davilv
Mensagens: 9
Registrado em: 17 Ago 2011, 16:06

Re: Instalar com versões mais novas do postgres, tomcat e ap

Mensagem por davilv » 07 Out 2011, 16:38

Lucas, só mais uma coisa, eu tinha te perguntado como eu altero a senha do usuário postgres, pra não deixá-la como padrão, e a do usuário do BD biblivre tbm. Qual arquivo que posso alterá-los?

t+

wlucas
Administrador
Mensagens: 1975
Registrado em: 30 Abr 2011, 10:38

Re: Instalar com versões mais novas do postgres, tomcat e ap

Mensagem por wlucas » 07 Out 2011, 17:03

Boa Tarde Davilv.

Veja no PgAdmin III, em Login Roles, lá no final à esquerda.

Atenciosamente. :ugeek:

davilv
Mensagens: 9
Registrado em: 17 Ago 2011, 16:06

Re: Instalar com versões mais novas do postgres, tomcat e ap

Mensagem por davilv » 07 Out 2011, 17:48

Lucas, mas então se eu for instalar numa máquina que já tenha o postgres instalado, então eu tenho que alterar o sua senha pra abracadabra e depois mudá-la novamente??
E o usuário biblivre tem mesmo que ser super user do postgres? Não funciona se ele for só do banco biblivre3?

obrigado.

wlucas
Administrador
Mensagens: 1975
Registrado em: 30 Abr 2011, 10:38

Re: Instalar com versões mais novas do postgres, tomcat e ap

Mensagem por wlucas » 11 Out 2011, 13:51

Boa tarde Davilv.

"Lucas, mas então se eu for instalar numa máquina que já tenha o postgres instalado, então eu tenho que alterar o sua senha pra abracadabra e depois mudá-la novamente??"

O ideal é vc testar, e caso der erro com a senha diferente de "abracadabra", ai sim fará alteração da senha.

"E o usuário biblivre tem mesmo que ser super user do postgres? Não funciona se ele for só do banco biblivre3?"

Não ficou muito claro essa pergunta, mas vou tentar responder...

O usuário biblivre precisar ser super no banco biblivre3 e é usuário somente desse banco, já o usuário postgres é o super para qualquer banco.

Atenciosamente. :ugeek:

Responder

Voltar para “Instalação do Biblivre”