Não consigo instalar o Biblivre 5

Forum para usuários do Biblivre 5
joseafonso123az
Mensagens: 7
Registrado em: 26 Set 2018, 17:18

Não consigo instalar o Biblivre 5

Mensagem por joseafonso123az » 26 Set 2018, 17:24

Olá!

E estou tentando instalar o biblivre mas sem sucesso.
Na máquina onde estou a instalar já tenho instalados o postgres 10 e o tomcat 9, e não sei se o biblivre aceita a instalacão com estas versões. O erro que vem sempre é de que não é possivel encontrar o postgres instalação abortada.

É a primeira vez que tento instalar o Biblivre pois pareceu-me um aplicativo potente.

cleydyr
Administrador
Mensagens: 667
Registrado em: 19 Jul 2017, 19:43
Localização: Recife

Re: Não consigo instalar o Biblivre 5

Mensagem por cleydyr » 26 Set 2018, 17:50

Olá, @joseafonso123az. Seja bem-vindo ao Fórum Biblivre 5.

Essas versões do Tomcat e do PostgreSQL podem simplesmente ser incompatíveis com o código atual do Biblivre (eu já conheço uma limitação código para funcionar no Tomcat 8). Não recomendaria fazer essa implantação. Se puder use uma máquina virtual ou um contêiner Docker para implantar. Já escrevi artigos sobre como instalar no Ubuntu e no Docker.

Abraço!
Github
Medium
biblivre.cloud: sua biblioteca online sempre estável, a partir de qualquer lugar

joseafonso123az
Mensagens: 7
Registrado em: 26 Set 2018, 17:18

Re: Não consigo instalar o Biblivre 5

Mensagem por joseafonso123az » 27 Set 2018, 10:05

Já instalei com as aplicações recomendadas. Tive que deletar tudo até o postgres nos registry keys para poder funcionar.
Criei novo post, pois estou encontrando outro problema.

joseafonso123az
Mensagens: 7
Registrado em: 26 Set 2018, 17:18

Re: Não consigo instalar o Biblivre 5

Mensagem por joseafonso123az » 27 Set 2018, 12:17

Acabei instalando no windows com as versões indicadas! Mas agora não consigo fazer o restore de um backup que me deram do biblivre 3. E no postgres fiquei com duas base de dados, uma que é o biblivre4 ( Não devia ser 5?) e a outra base de dados é do backup

cleydyr
Administrador
Mensagens: 667
Registrado em: 19 Jul 2017, 19:43
Localização: Recife

Re: Não consigo instalar o Biblivre 5

Mensagem por cleydyr » 27 Set 2018, 14:55

joseafonso123az escreveu:Acabei instalando no windows com as versões indicadas! Mas agora não consigo fazer o restore de um backup que me deram do biblivre 3. E no postgres fiquei com duas base de dados, uma que é o biblivre4 ( Não devia ser 5?) e a outra base de dados é do backup
Essa questão da base se chamar biblivre4 (e não 5) já é conhecida, mas é um detalhe interno, que você pode ignorar.

Vou trancar esse tópico para evitar inundação de posts não relacionados. Se precisar de assistência pode abrir outro tópico.

Abraço.
Github
Medium
biblivre.cloud: sua biblioteca online sempre estável, a partir de qualquer lugar

Trancado

Voltar para “Fórum Biblivre 5”